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General Excel Directions 
 
 To select, copy, & paste a large block of data:  Click in upper left corner of 
needed data, then scroll to bottom of needed data, and shift-click in lower-right corner of 
needed data.  Choose Copy.  Go to where you want the data and click in the upper left 
corner of where you want the data to be.  Choose Paste to put in the data. 
 Copying a formula:  Type in the formula you want & press return; check that the 
formula has worked as expected.  Click in the cell with the formula to select it.  Place 
your cursor over the black box at the lower right of the selected cell; the cursor will 
change from the usual large plus to a small +.  Click and drag the + over the cells where 
you want to copy the formula, and release it when finished - check to see that it worked 
for all the cells you intended.  In some cases, a shortcut to the dragging is to simply 
double-click when you have the + cursor, and Excel will copy the formula to all the cells 
it thinks you might want, e.g., the rest of a column; however, this does not always work 
as you want, and will need to be checked. 
 Filling a series of numbers or dates:  If you need a column of numbers or 
dates, use 2 cells to start the series, e.g., 1, 2, if you want an interval of 1; or 5, 10 if you 
want an interval of 5; or 1/1/2003, 1/2/2003 if you want an interval of 1 day.  Drag your 
cursor over both cells to select them both.  Then (as in copying a formula, above), place 
your cursor over the black box at the lower right of the lower selected cell; the cursor will 
change from the usual large plus to a small +.  Click and drag the + over the cells where 
you want to fill the series, and release it when finished - check to see that it worked for 
all the cells you intended.  The same shortcut mentioned in copying a formula, above, 
may also work, but check its results. 
 
 
How to make & edit a chart (graph) 
 
1.  Starting a chart (graph): 

a.  Select data to be plotted by clicking on the letter at the top of the column for 
the relevant columns (these instructions assume the data to apply to each axis is in 
columns; if it's ever in rows, simply select whole rows instead).  If the columns you need 
are not adjacent, click one and then control-click the other one.  It will be best if data for 
X axis is to the left, Y axis data is to the right; otherwise, you will need to interchange 
them on the graph. 

b. Click Chart Wizard icon; the Steps that follow are the sequential windows in 
the Wizard. 

c. Wizard Step 1:  Select XY(Scatter) and choose the sub-type which has points 
and smoothed lines.  

d. Wizard Step 2:  If your graph looks basically OK at this point, click next; if not, 
go back and try again.   

e.  Wizard Step 3, the Chart Options window (you can get back to these choices 
at any time later, if needed):   

   1.  Titles tab:  Put in a correct title now and label the axes with their quantity & 
units. 
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   2.  Legend tab:  If you have only 1 line on this graph, you can uncheck the 
"Show legend" choice. 

   3.  Gridlines tab - Add whatever lines are needed to analyze your data 
effectively. 

f.  Wizard Step 4, Place chart:  Click "As new sheet" and give it a short name.  
Click Finish. 

g.  Now that you can see the chart, choose Chart -> Chart Options… if you see 
some things you need to change. 

h.  Save your workbook (data + graphs). 
 
 
2.  To edit an axis 

a.  When Excel sets up a chart using the Wizard, it adds space at the ends of the 
axis beyond the actual data plotted; this may waste space on your graph.  To make the 
range of the axis fit your data better, click on the numbers on the axis (boxes should 
appear on the ends of the axis itself), and choose Format --> Selected axis (you can 
also simply right-click on the numbers on the axis, and choose Format axis). 

b.  To change the range, click on the Scale tab, and type in the minimum and 
maximum you need - see date information below if this axis has dates.  This is also the 
place to specify the major and minor gridline amounts (major & minor units) if needed. 

c.  The format axis window is also the place to change a font size if needed. 
 d.  If you have dates on an axis - usually the X axis - it will help to understand 
that Excel handles dates as "serial values," which is the number of days since January 
1, 1900.  So, for example, here are some dates and their serial values that may be 
useful: 

Date  Serial value 
 10/1/1998 36069 
 10/15/1998 36075 

10/1/1999 36434 
10/1/2000 36800 
10/1/2002 37530 

 12/03/2002 37600 
10/1/2003 37895 

The serial values are what you will need to type into the minimum and maximum boxes 
to specify a particular range of dates on the axis.  The major & minor units will also be in 
days, such as 30 for approximately monthly, 91 for quarters of year, and 365 for a year; 
these will vary some since the lengths of months, and years, vary.  Note that the source 
data for a graph can be an entire column of dates, but if the axis only includes part of 
those dates, that part will be the only data on the graph - this is useful for looking at 
various parts of the data by simply changing the minimum & maximum on the axis. 
 
3.  To add a 2nd data series, which will use the secondary or right-hand axis for 

its scale: 
a.  Look in the data at what is the column letter for the data you're adding. 
b.   Select Chart -> Source Data... -> Series tab. 
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c.  Click in Name block and give a name for the data already entered.  This is the name 
that will appear in the legend. 

d.  Select all of the X values info and Copy it. 
e.  Click the Add button 
f.  Click in the X values space and Paste the X values info. 
g.  Click in the Y values space and paste again.  Then click within this info and change 

the column letters in the Y values space to the letter for the data you want to 
add.  Note that arrow keys don't work on these lines - click to get the cursor 
within the info where you need to make a change. 

h.  In the Name box, type in a name for the new data series. 
i.  Close the Series window. 
j.  Don't worry that your graph probably looks very strange right now; this is because it is 

currently plotting both sets of data using the same scale even though the 
numbers may be very different.  To correct that, click on the graph on one of the 
data dots for the data you just added.  Choose Format -> Selected Data 
Series..., select Axis tab, and click Secondary axis.  Click OK and the graph 
should look better. 

k.  Go to Chart -> Chart Options to label the new Second value (Y) axis with a name 
and units. 

l.  A chart with only one Y axis doesn't really need a legend, but a chart that has 2 lines 
on it does need a legend.  Your charts will be wider if the legend is located at 
the top, which can be changed under Chart Options. 

 
4.  Copying graphs:  If you are making multiple graphs, once you have the first graph 

done, it may be easier to copy it and just change the Y axes column letters and 
labels.  To make a copy: 

a.  Go to the chart you want to copy and choose Edit -> Move or Copy Sheet... 
b.  In the scrolling box, choose the last item that is "(move to end)", and check off 

"Create a copy", and click OK. 
c.  When you have the new chart, double-click on its tab at the bottom of the screen and 

type in a new name for this chart that reflects the new data it will chart. 
d.  Determine the column letters that contain the data you want for this new chart.   
e.  Choose Chart -> Source Data... and re-type column letters.  Remember the X values 

(e.g., time) may stay the same for your new graph; if so, change only Y values, 
names, and axes labels.  Note that arrow keys don't work on these lines - click 
to get the cursor within the info where you need to make a change. 

f.  Save the workbook after each chart is completed.  
 
5.  Editing lines and points 
To edit the lines (thickness, color) or the points (called markers, editing their shape or 
color), first click on the chart on the line/points you want to edit - some new marks will 
show on the line to indicate it is selected, but these marks won't cover every data point.  
Then choose Format -> Selected Data Series - > Patterns tab.  Then you can edit either 
the line or the markers.  You can also choose None to eliminate either the line or the 
markers. 
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Notes for specific charts used in the BES Exploring Watersheds in Baltimore 
Module 
 
Charts 1 to 3 

a.  On Charts 1 to 3, if both Y axes are at zero at the bottom of the chart, much of 
the discharge lines will plot on top of each other and so be hard to see.  To fix this, lift 
one or more of the lines up from the bottom of the chart by editing one axis so it has a 
negative value for its minimum (see instruction 2 above) - it will be best to do this for the 
axis with the smallest overall range.  Of course, the stream discharge will never have a 
negative value; this is just a way to raise the zero line off the bottom of the graph. 

b.  Due to the large amount of data on this chart (if you include several years of 
data), it will be better if the graph lines do not have a marker on them, and instead are 
just lines.  To do this, go to Chart --> Chart type..., and select the XY scatter graph that 
does not have marker points; or see instruction 5 above to edit individual lines. 

c.  If you only need to use the BES streams 
 
Charts 4 & 5 
To create these charts, the data must be developed from the basic discharge data. 

a.  First determine a value for base flow: Go to the bottom of the column of 
discharge data and finding the average discharge by typing in a formula similar to   
=AVERAGE(C2:C1462)   where C2 to C1462 contains the discharge data.  In this case, 
the average can be thrown off by exceptionally high values, and zero values, so other 
measures of central tendency may be more useful.  So also calculate  
=MODE(C2:C1462)   and   =MEDIAN(C2:C1462).  Decide on a best base flow value 
based on these numbers, and make another cell for the value you choose (for example, 
cell C1469); by putting this value in a separate cell, we can refer to it in another formula, 
but easily change it and Excel will re-calculate all formulas and graphs that use it.  Look 
at your graph of discharge and see if the value you have chosen for base flow is a 
sensible one for the normal flow of the stream. 

b.  Next calculate the multiple/fraction of base flow:  At the top of a new column, 
type in the formula to determine multiple/fraction, which is simply dividing the day's 
discharge by the base flow amount chosen in step (a) above, e.g.,  = C2/$C$1469  , 
where C2 has the first daily discharge value, and C1469 is where your base flow value 
is located.  The $ signs tell Excel to always use cell C1469 even when the formula is 
copied to the rest of the column, as the C2 will change to C3, then C4, and so on, but 
we want the C1469 reference to stay constant.  Copy this formula for the rest of the 
discharge data, and graph it by the usual steps.  Note that these charts have only a few 
months of data graphed, so the details of individual lines are visible. 
 
Charts 6-8 
 a.  For all water quality charts, be sure each line plotted uses the dates that go 
with that quantity, as not all water quality measures appear for a particular date.  So, for 
example, the line for Villa Nova is columns E and F to get dates & data, then Carroll 
Park is columns G and H to get dates and data, and so on. 
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 b.  Charts 6 & 8 should have no markers because they are a large amount of 
data.  Chart 7 is somewhat less, and can have markers, especially to differentiate the 
lines if the chart is to be printed in black & white. 
 c.  Chart 8 is a copy of Chart 6, with snow data added as a new Series, plotted 
on the secondary (right) Y-axis; this axis has been given a negative minimum to raise 
the dots for snow amounts so they are easier to see and d o not obscure as much of the 
chloride ion line.  Since the snow amounts are discrete daily values, they should not 
have a line connecting the points. 
 
Charts 9 & 10 
 a.  See note (a) above for Charts 6-8. 
 b.  Because the McDonogh site didn't start until late 1999, Chart 9 is for 1/1/2000 
to 12/3/2003 (days 36526 to 37593).  This data is sufficiently spread apart that you can 
put markers on it, especially if you want to print it in black & white. 
 c.  Since Chart 10 has a lot of data on it, it is better to have no markers on the 
lines. 
 
Downloading USGS stream data 
 

1.  Go to the USGS web site for water at:  <http://water.usgs.gov/>. 
2.  Select NWIS-Web (if needed), then Surface Water, then Streamflow. 
3.  When first using the site, you will probably want to look at a list of stream 

gages in Maryland.  Asking for them listed by site name, grouped by county, may help 
you find a particular site.  Look through the list to find streams in your area, and note 
their number. 

4.  Then return to screen where you can specify that you want to type in a site 
number, and type it in.  Once you are on the page for that site, you may want to select 
the site map to see where the gage is.  It may also be of value to note the area of the 
watershed for your stream. 

5.  Once you know a site you want to use, type in the dates that you want; note 
that there may be data gaps between the starting and ending dates shown, and the only 
way to see if or where those gaps are is by requesting the data.  You should request 
tab-separated data, and specify the date format as MM/DD/YYYY so the data will go 
into your spreadsheet easily.  Give the saved data file a distinctive name so you can tell 
what it is, especially if you get data for several streams or various time periods, and add 
a ".txt" ending if needed. 

6.  Open Excel, and open your discharge text file.  Excel will start its Text Import 
Wizard; you can probably just press Next for each screen, and the data will be imported 
into Excel.  Read the information provided so you understand what column is what data, 
then you can delete any extra lines or columns except dates and discharge amounts. 
 


